2010 Ralliart Oxygen Sensor/Rough idle

Discussion in 'Ralliart - General Information' started by TYDARalliart, Aug 28, 2017.

  1. TYDARalliart

    TYDARalliart New Member

    Hey Guys, this is my first post on here but very excited to continue to be a part of this.

    So here's the deal with my 2010 Ralliart. The engine light is on and I used my code finder to see that my oxygen sensors are failing. My exhaust smells very rich and I'm burning fuel like nobody's business even while driving conservatively. Not knowing if the abnormal idle is related to the O2 sensors being bad, I changed all plugs and thoroughly cleaned my MAF Sensor. I've noticed a slight improvement, but nothing has been actually solved.

    I have had an idle that sits at 2,000rpms drops to 1,500rpms for about 5 seconds then continues the cycle again. I realize that this seems like an easy fix, "just buy the O2 sensors and install them".
    My problem is that I don't exactly want to pay $250 each for two O2 sensors from Autozone, but I have found one for pretty cheap but I'm afraid of it's quality and that it might do more harm than help the situation. Here's the links:

    Autozone O2 sensors
    http://m.autozone.com/engine-manage...ch-oxygen-sensor/181373_102074_1784?location=

    Cheap O2 sensors http://www.carparts.com/details/Mit...Vm4uzCh25JQP2EAQYASABEgI45PD_BwE&gclsrc=aw.ds

    What are your guys' thoughts? My last issue is that YouTube is no help when trying to locate these O2 sensors for me to start this repair. Any input is appreciated! Thanks